DVD Library in Media Center

From JRiverWiki

Jump to: navigation, search

This article describes how to use Media Center to manage a DVD library collection. This article describes how to import, manage and playback DVDs in MC library. It also describes how you can watch these DVDs on multiple computers on the network.

Contents

How to extract DVDs to your hard drive

If you are here, you probably already know how to extract DVDs to your hard drive. If you do not, there are helpful sites on the internet that can help. There are primarily two ways you can extract a DVD to hard drive: as a single .iso file or as a VIDEO_TS directory with multiple files in that directory. MC12 supports and can playback DVDs extracted in either format.

Playback on local computer

First, ensure that you can playback your extracted DVDs on a computer with direct (i.e. non-network) access to hard drive with extracted DVDs. Both methods of extracting DVDs require different steps.

VIDEO_TS folder

Just import the VIDEO_TS folder into your MC library. This should import a .ifo file named VIDEO_TS in the VIDEO_TS directory. Just double-clicking on this file should start DVD playback. Due to the simplicity of this method, this is what I would recommend if you haven't already extracted your DVDs. You can assign cover art for the movie to the .ifo file and it would look nice in the theater view or album thumbnails view.

ISO file in MC12

It is slightly more work to playback ISO files in MC.

  • Download and install Virtual clone Drive software - it is free.
  • Enable shell integration feature of virtual clone drive.
  • Open the folder that contains the .iso file in Windows Explorer. Make sure that when you double-click on .iso file it is mounted on your virtual drive. If shell integration is enabled in virtual clone drive then the file should mount on virtual drive upon double clicking it in windows explorer.
  • Drag and drop the .iso file or the folder that contains .iso files to MC window. Or, right click on the folder containing .iso file and click on Media Center -> Import (assuming that the shell integration feature of MC is enabled). MC will import all the .iso files in its library.
  • These .iso files are visible under Documents in MC. Double click on the .iso file inside MC. This should mount the file on the virtual drive. You can set-up MC to start playing DVD automatically in full-screen mode (Display View) when DVD is inserted. If you have setup MC this way, DVD should also start playing in full-screen mode when you double click the .iso file inside MC.
  • The .iso files can also show up under Video in Theater View. To do this, change the Video view scheme to include both Video and Documents data type. In Standard View, there are three Audio, Images and Video buttons on the left. Right click on Video button and select "Edit View Scheme". This will pop up a dialog box where you can select Media Type under Step 4 (at the bottom of the window). By default it would have Media Type: Video. Click on Video there and select "Edit (with wizard)". This would show a Media Type window. In that select both Data and Video and click OK. Now, the View Scheme window should show Media Type: Data, Video. Click OK. Now, when you click on Video in theater view you should see all documents in it too. If you have other documents than .iso files in your documents tree (such as .txt etc. files) then you should get rid of them if you don't want them to be seen in theater view.


Since recent MC12 versions (12.0.251 and later), it is now possible to assign cover art to .ISO files as well. In order to do this, edit the "Media Type" tag of the .ISO file to Video. Now, assign cover art to .ISO file as you would normally do. Now, change the "Media Type" tag of the .ISO File to Data. You will have cover art assigned to the .ISO file now and you should be able to play the .ISO file as well.

ISO file in MC13

For Newer Versions, please see the ISO Files Wiki topic.

In MC13 the process is slightly different as you can assign a "Playback Method" by File Type.

  • Firstly, change how MC13 handles the launching of ISO's: Under "Tools --> Options --> File Types", scroll down to the "Data" Section, Select "Disk Image Files" and change the Playback Method to "External Program (default). MC13 will now use Windows default setting to "mount" your ISO's with your default mounter (eg Virtual Clone Drive / Daemon Tools etc).
  • Tag your ISO Files: You now need to tag each of your ISO files as Video, Audio etc pending on what view you want them to appear in. To do this select you ISO file(s) and change the "Media Type" Library Field to the correct type (eg, "Video" but could be "Audio" if you ISO your CD's). You can then assign Coverart (if desired) as with any other items in the database.

All your ISO's should now apear in the correct area of TheaterView and will Mount, Launch and Play just as you would expect.

Playing DVDs on remote computer

MC12 has powerful Library Server features which provides capability to share your music, video and images between multiple computers on your network. Library Server works very well for different types of media over a variety of network infrastructure. However, Library Server does not work with DVDs extracted on your hard drive. If you are interested in using MC12 to manage your DVD library collection, it is possible using network shares.

Set up a network share for the directory that contains the media files. Make sure that the network share is mounted on the same drive letter (say H:) on all computers. On the computer that has local access to the hard drive containing your media directory (say C:\Media), you can mount it as H: by creating a .BAT file that contains:

   SUBST H: C:\Media

Set a link to this .BAT file in the Startup folder so it is executed every time when computer is started.

Create the media library on the local computer in terms of H: and not C:\Media. That way you can use the same library in multiple computers.

Synchronizing MC library across multiple computers

There are many reasons for syncronizing MC library over multiple computers (rather than just setting up separate libraries on each computer).

  • No need to import newly added files into each library separately.
  • All tags are identical between computers. Some files do not store tags in the file (e.g. video files, some audio file types etc.). It could be a lot of work to ensure that all tags are identical between multiple computers without a shared library. Ditto for cover art.
  • Thumbnails have to be created for each library separately. This could be a process that could take long time when media is on a shared network drive.
  • Customized views and view options are shared between synchronized libraries. Otherwise, one needs to make the same configuration changes in all computers separately.

Synchronizing MC library and the thumbnail database between multiple computers can solve all these isues. In order to do this, we need to understand where MC stores the library and the thumbnail database. MC Library is stored by default in the directory

C:\Documents and Settings\[User Name]\Application Data\J River\Media Center 12\Library

where [User Name] is your user name. The thumbnails database is created by default in the directory

C:\Documents and Settings\[User Name]\Application Data\J River\Media Center 12\Thumbnails

To synchronize MC Library between multiple computers, essentially one needs to make these directories identical on multiple computers. Make sure that both computers are running the same version of MC. This means when you update MC on one of the computer, you have to do the same on all the computers. When you copy these directories between multiple computers, both computers should not be running MC.

For both of the following two methods, you will need to change the default location of these two directories.

Changing the Library directory

In MC12, select the menu File -> Library -> Library Manager. Here you can add or edit a library and change the directory where the library is stored. I would recommend giving identical names to the Library on all computers. More information is at Library Manager.

Changing the Thumbnails directory

It is slightly more cumbersome to change the thumbnails directory. This can be done using registry edit. Use regedit.exe to change the registry. If you haven't used regedit before, proceed with caution. Make sure you save and back up your registry. Change the registry entry

HKEY_CURRENT_USER\Software\J. River\Media Center 12\Properties\Thumbnails - Base Path

to point to where you want thumbnails to be stored at. It is highly recommended to use a local hard drive folder and not one on network to ensure smooth performance. Build thumbnail database on the faster machine with local access to media files. Thumbnail database can be created by choosing the menu Tools -> Options -> Tree & View -> Thumbnails -> Build missing thumbnails (Tree & View Settings).

Method 1: Shared Library

In this method, the Library directory is on a shared drive, say at H:\Library. And the thumbnails directory is on local hard drive, say C:\Library\tn. All the media must be on the shared drive H:, of course. You will not need to copy the library directory manually between the two machines but you will need to copy the thumbnails directory.

Pros of this method:

  • Tags can be edited by any machine on the network. The first machine to open the library has the read-write access to the Library.
  • All machines always have the same library. Nothing needs to be done to keep the machines in sync.
  • Play counts from all machines are combined (Can someone edit this page and confirm this?)

Cons of this method:

  • Putting library on a network share may not be practical if the network share is on a slow network. Don't use this method if you have wireless home network.

Method 2: Shared Media but different Libraries

In this method, both Library and the thumbnails database are stored on a local drive. I recommend storing the library in C:\Library directory and the thumbnails database in C:\Library\tn directory. That way, you need to synchronize only one folder (C:\Library) between two computers. You should use one of the computer where you do importing, tagging, thumbnails database creation etc. Once, you have completed this, just synchronize C:\Library folder between the computers.

Pros of this method:

  • Works on slow networks such as wireless networks.

Cons of this method:

  • Only one machine should be editing tags if all libraries are supposed to maintain identical structure.
  • Play counts from different machines are not combined together.

How to synchronize folders between multiple computers

In either of the two methods, you need to synchronize folder on local drive between two computers. The simplest way to do this is to copy the folder (e.g. C:\Library in the Method 2 above) on the shared drive on the first computer and then copying it from shared drive to local drive on the second computer. This method works reasonably well but you may find that it is not optimal in the sense that even if only one file is changed, you are copying the entire directory. If you would like to copy only the changes, you can use unison. Unison is very smart about finding only the differences and only transferring the differences between the two machines. I have found that it reduces the time to copy the folders by an order of magnitude.

Personal tools